注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

星期五

明天不上班

 
 
 

日志

 
 
关于我

一个特立独行的Java程序员,比较宅,上上网,写博客,听音乐,看电影。

网易考拉推荐

你有没有遇到 psql 8.4.9, server 9.1.3 ?  

2012-06-24 20:46:56|  分类: Postgresql |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

环境:rhel6.2 postgresql 9.1.3,使用安装包postgresql-9.1.3-1-linux-x64.run


[root@rhel62-1 demo-data]# su postgres
bash-4.1$ psql -U postgres
Password for user postgres: 
psql (8.4.9, server 9.1.3)
WARNING: psql version 8.4, server version 9.1.
         Some psql features might not work.
Type "help" for help.

postgres=#


使用pg_restore 报错,是因为psql version的版本过低

bash-4.1$ pg_restore -U j -d j ./j.dmp.tar 
pg_restore: [archiver] unsupported version (1.12) in file header


原因找到了,之前装OS的时候,选择是developer,默认装过8.4,只需要source pg_env.sh(在postgres的安装目录)

  评论这张
 
阅读(1001)| 评论(0)
推荐

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017